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QlikView Plugin is Installed but not Available to Use on AccessPoint

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ToniKautto
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QlikView Plugin is Installed but not Available to Use on AccessPoint

Last Update:

Jun 4, 2021 3:38:52 PM

Updated By:

Andre_Sostizzo

Created date:

Dec 1, 2014 7:21:54 PM

QlikView Internet Explorer (IE) plugin is not an available option in QlikView Access Point, even though it has been installed on the client machine. 

Confirm that the following conditions are true.
  • The QlikView Plugin is available in Windows Control Panel > Programs and Features
  • The QlikOCX control is not available in Internet Explorer > Tools > Manage Add-ons
  • QlikView Access Point is accessed through Internet Explorer.

 

Cause:


This could occur if either of these statements are true.

  • QlikView Plugin has been installed with insufficient privileges
  • The QlikView Plugin MSI package has been pushed out the users and has not been configured so it is registered correctly for the user
  • Security settings do not allow Active X control

 

Resolution:



1) The component QlikOCX.ocx needs to be registered manually.

  • Locate the file QlikOCX.ocx. The default path is C:\Program Files\QlikView\QvPlugin\
  • Register the file from "Run" or "Command Prompt" using regsvr32:
regsvr32 "C:\Program Files\QlikView\QvPlugin\QlikOCX.ocx"
 
000005503a.png

 

Note

  • If you are running a 64-bit OS you will need to specify the full path to the x86 version of regsvr32 and QlikOCX will be located in Program Files (x86):
"C:\Windows\SysWOW64\regsvr32.exe" "C:\Program Files (x86)\QlikView\QvPlugin\QlikOCX.ocx"
  • If you are running an OS with User Account Control activated you might need to start "Run" or "Command Prompt" with elevated privileges by right-clicking the program and selecting "Run as Administrator".


* Would be good to try uninstall from Windows Control Panel > Programs and Features, restart PC and install again to solve the issue.

2) The active X control that checks if the plugin is installed does not work

  • Check if the website is in "Trusted websites" and that Active X is allowed.


If for any reason, Active X cannot be allowed for this website, the following workaround can be used to always show the plugin link on the access point (Be aware that the change will be reverted at each QlikView upgrade and that the link will be displayed even if the user has not installed the plugin) 
* This workaround is only applicable if opening the direct qvp link to the document works (plugin correctly installed) but that the link to open it with the IE plugin does not show up on the access point.

  • Modify C:\Program Files\QlikView\Web\js\accessPoint.js and add the line in bold below:

ap.checkPlugin = function () { 
pluginEnabled = false; 
if (navigator.userAgent.indexOf("MSIE") != -1 ){pluginEnabled = true;} 
var a = ap.getCookieValue("pluginEnabled"); 
if (a === null) { 
try { 
if ((!IS_IE11_OR_ABOVE && ActiveXObject) || (IS_IE11_OR_ABOVE && ("ActiveXObject")in window)) { 
ap.OCX = new ActiveXObject("QlikTech.QlikOcxCtrl"); 
document.cookie = "pluginEnabled=true; path=/"; 
pluginEnabled = true 

} catch (b) {} 

} else { 
if (a === "true") { 
pluginEnabled = true 


}; 

 

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Last update:
‎2021-06-04 03:38 PM
Updated by: