Diagnostic for possible causes of memory shortage/insufficient resources. QlikView systems can be affected by resource issues and resource problems, such as high CPU usage or a lack of free, available RAM.
Symptoms of a virtual memory shortage:
- Warning WorkingSet: Virtual Memory is growing beyond parameters
- Warning WorkingSet: Virtual Memory is growing CRITICALLY beyond parameters
- Error Memory: Total memory exhausted.
- Error Restart: Server aborted trying to recover by restart. Reason for restart: Internal inconsistency
- Error PGO: Failed to open C:\P\CalD. Error: 3
- Host Operating System becomes unresponsive
- Documents load slowly, or not at all.
- Connection Lost displayed on the AccessPoint when attempting to open a QlikView Document
- No Server diplayed on the AccessPoint
Environment:
QlikView any version
Cause:
Insufficient resources
Resolution:
See Troubleshooting a QlikView Server: Performance and crashes
Basic hints:
- If the system is running in a virtual guest system, ensure that resources are dedicated. See QlikView Server Virtualization
- limit the amount of concurrent sessions allowed
- develop the application(s) for optimal memory footprints
- fix any applications causing the resource issues
- reduce the amount of Publisher/Server task reloads
- limit application development on the server
- free up resources by disabling other applications
- increase your hardware resources